Wednesday, July 25, 2012

Episode 164 of RFC

Legally Blonde And Mother Nang on RFC 164

July 25, 2012 by rudy panucci
Up there is Radio Free Chaleston’s 164h episode, “Fighting English Shirt,” which features music from The Charleston Light Opera Guild production of “Legally Blonde” and a song from Mother Nang, along with a brief bit of strange uncredited animation.

Cameron Vance and Micah Atkinson
The CLOG production of “Legally Blonde” stars Micah Atkinson as Elle Woods, along with a large talented cast that includes Matthew Bryant, Allison Plants, Michael D. Gore, Cameron Vance, Toni Pilato, and Rudi Raynes-Kidder along with many others. The RFC cameras were allowed in for the first dress rehearsal, and we witnessed a show that is coming together quickly and looks like a lot of fun. We bring you two numbers from “Legally Blonde” this week, “Serious” and “What You Want.”

Monday, July 9, 2012

Episode 163 of RFC

RFC 163: Cool Music For Hot Times

July 9, 2012 by rudy panucci
Above you should see “Misfits of WV Shirt,” this is our low-key sixth anniversary show. After producing almost three hours of FestivAll coverage, we decided to just do a normal-length show for our anniversary. But it’s still a special show! Host segments were shot at Dutch Streetwear on D Street in South Charleston. You may remember our friends The Salvage Yard from The Charleston Town Center, well, they have a new name, and a great new, larger location in South Charleston, within sight of the Mound. We also have great music from Red Audio, Tofujitsu and Mother Blues. Plus we have animation.

Wednesday, June 27, 2012

Episode 162 of RFC

Part Two of FestivAll 2012 on RFC 162

June 27, 2012 by rudy panucci
i
Radio Free Charleston’s coverage of FestivALL 2012 continues this week with another bonus length episode

West Virginia Dance Company
featuring tons of music, dance, film, and other stuff.  The city became a work of art and we were there pointing our cameras right in its face.

We kick off with The Bob Thompson Unit, captured at The Shops at Bridge Road, performing on the West Virginia Music Hall of Fame bandwagon.  With the Bob Thompson Unit’s smooth jazz playing behind them, we cut to footage of the West Virginia Dance Company, recorded at the Charleston Town Center Mall.

Monday, June 18, 2012

Episode 161 of RFC

RFC Does FestivAll 2012: Part One

June 18, 2012 by rudy panucci
Every year during June, Charleston, West Virginia is a city that becomes a work of art. For the past few years, Radio Free Charleston has been there to immortalize parts of this city-wide event in internet videodom.  This is the first of two special episodes of Radio Free Charleston devoted to the sights and sounds of FestivAll 2012.

Included in this show is music from Red Audio, Andy Park, Emily Burdette, The Kanawha Kordsmen and Sweet Adelines and Paul Calicoat. We are also treated to an Effects Makeup demonstration by Rob “RJ” Haddy, a finalist on the SyFy program, “Face Off.”  Much of the show is devoted to the FestivAll Art Parade, while we finish with scenes of The East End Main Street Streetworks Art Auction and Celebration, and auctioneer Ted Brightwell.

Among the Art Parade fun you’ll see Razor Sharp Productions with Porkchop and Pig Girl, Dale Morton Studio Mascots, Zombies and ghouls from Shocka Con, The West Virginia Music Hall of Fame, The Chemical Valley Roller Girls, The Charleston Light Opera Guild and more!

We didn’t come close to making it to every cool event, but what we did capture was loads of fun. Next week we will bring you part two of our coverage, with music recorded at Thursday’s Derick Kirk Scholarship Benefit, and cool stuff from next weekend’s Capitol Street Art Fair, plus tons of other cool things.

Tuesday, June 12, 2012

Episode 160 of RFC

Radio Free Charleston’s 2012 FestivAll Preview

June 12, 2012 by rudy panucci
Above this text you see RFC 160, “Deep And Dangerous Shirt,” our FestivAll stream-of-consciousness preview/sampler show. We tell you about some of the cool things happening during FestivAll, and we give you some examples of the artists and performers on display. This is not, by any means, a comprehensive guide–for that, visit the FestivAll website. This is just a sampler, so enjoy!

We kick things off standing in The Lee Street Triangle, where, on Saturday July 16, at Noon, there will be a free edition of Dr. Sketchy’s Anti Art show, where anybody who wants to will get the chance to do some live figure drawing.

Monday, May 28, 2012

Episode 159 of RFC

The Big Bad, In The Company Of Wolves, Foz Rotten, “One Soldier, One Grave” And An Act Of Defiance Celebrated on RFC 159

May 28, 2012 by rudy panucci
That’s Radio Free Charleston 158, “Cap Seniors Shirt,” that you see at the head of this post.  This episode of the show is named after the controversial shirt that was all over the news last week.

We’ll tell you the story of the shirt at the end of these production notes. That will come after we tell you aout The Big Bad, In The Company of Wolves, Foz Rotten and Dennis Strom’s film, “One Soldier, One Grave.”

Our host-segment story is meaty tale of pointless defiance. But first, our guests this week…

Monday, May 21, 2012

Episode 158 of RFC

The Liquid Canvas of James Vernon Brown

May 21, 2012 by rudy panucci
RFC 158
JVB, himself
Radio Free Charleston’s 158th episode, “The Liquid Canvas,” is devoted to the work of Charleston filmmaker, musician, and artist James Vernon Brown. I first met James back in 2007, when we recorded the band Doctor Senator. James was playing bass and had also made several cool short films and music videos featuring the band.

James ended up leaving Doctor Senator and, at a jam session at The Blue Parrot one night, I heard him play guitar for the first time and was blown away with his David Gilmore meets Jimi Hendrix six-string pyrotechnics. I remember going up to him after hearing him play and asking “why the hell were you wasting your time playing bass?”

Monday, April 30, 2012

Episode 157 of RFC

The Color Purple, Godmode Brodway And A Plea

April 30, 2012 by rudy panucci
That’s Radio Free Charleston 157, “The Mighty Thor Shirt,” you see up there in the box above this text. This week we are bringing you three songs from the newest production by the Charleston Light Opera Guild, plus we have some new music from Godmode Broadway, and a heartfelt plea from The Tom McGees. Host segments were shot around The Charleston Civic Center.

The Charleston Civic Center Little Theater is the site of theCharleston Light Opera Guild production of the musical version of “The Color Purple.” The beloved novel by Alice Walker was turned into a Broadway musical a few years ago by Brenda Russell, Allee Willis and Stephen Bray, with a book by Marsha Norman, and it is the spring offering from Charleston’s Light Opera Guild, opening May 4.

Monday, April 16, 2012

Episode 156 of RFC

Funkadelic Zombie Ska Madness On RFC 156

April 16, 2012 by rudy panucci
Radio Free Charleston 156, “Warning Trioxin Shirt,” is posted above for your enjoyment. This week we have music from The Renfields and The Tom McGees, plus we have a terrific short docu-drama by Stephen Schmidt. But first, we have some corrections to do.

I’m pleading allergy-induced dementia for this. First, the Tom McGees’ song that I call “Be Smart” in the show, and “Be Strong” in the credits, is actually called “Enemy Spy Plane Inbound.” I know, it’s an easy mistake to make. Compounding the errors, I announce that The Tom McGees are playing the Porkchopp3D Trailer Release Party April 26 at The Empty Glass, when in fact it is our other musical guest, The Renfields, who are going to be playing that show. Aside from the two huge mistakes in the scripting process, I was really happy with the host segments, which were shot outside of Kanawha Players Theater, the location of this weekend’s Zombie Prom.

Monday, April 9, 2012

Episode 155 of RFC

The Amorous, Godmode Broadway, DualCore and Stark Charleston Embiggen RFC 155

April 9, 2012 by rudy panucci
"Love Robot" by Rebekie B
Above you see Radio Free Charleston 155, “Love Robot Shirt,” featuring music is from The Amorous,Godmode Broadway and Dual Core, plus the return of Stark Charleston. Host segments were shot in the parking lot of the WV Division of Tourism in South Charleston. Our title shirt is a TeeFury design by artist, Rebekie B.

Our first musical guest on this week’s show is Clarksburg’s The Amorous. An indie-pop band with spiritual leanings, they will be recording their first full-length album this summer. You can catch them next weekend in Wilmington and Bellbrook Ohio, and at the end of the month they’re doing a three-night stand at The Horizon’s Church in Lost Creek WV. We recorded the band live during Charcon last year, and assembled this video using audio enhanced with a studio recording.