Monday, September 24, 2012

Episode 169 of RFC

Great Music, Strange Film and A Very Dark Mound On RFC 169

September 24, 2012 by rudy panucci
Radio Free Charleston 169, “The Black Knight Rises,” features music from Emily Burdette, Godmode Broadway and The Nanker Phelge, plus two short films by Frank Panucci. Host segments were shot at The Mound in South Charleston about an hour later than we’d planned, and we plug a couple of cool local events, both of which are coming up this Saturday.

This week’s episode is hosted from The Mound in South Charleston, where September 29, part of Shocka Con will take place. This year’s Shocka Con will be a fundraiser/preview of what organizers hope will be a full-blown horror and fantasy convention next year.

Monday, September 10, 2012

Episode 168 of RFC

Part Three Of Tribute To The Troops on RFC 168

September 10, 2012 by rudy panucci
At the top of this post you should see Radio Free Charleston 168 “Zelda by Megan Lara Shirt” (Tribute To The Troops II part three).This is the final installment of our three-part special devoted to Tribute To The Troops II, an all-ages, all-day musical event held at The Saint Albans City Pak amphitheater for the benefit of The West Virginia National Guard Foundation and The Wounded Warrior Project.

Rudy, wearing Megan Lara’s Zelda
This episode brings you music from In The Company of Wolves, Point of Jerus, Deck of Fools and a very special song from HarraH. We also have a short film about The West Virginia National Guard Foundation narrated by Melanie Larch, with video contributions by Steven Allen Adams and West Virginia Public Broadcasting. Our namesake shirt is a Teefury design by up-and-coming designer, Megan Lara, who is destined to be a star soon.

Monday, September 3, 2012

Episode 167 of RFC

More From Tribute To The Troops II on RFC 167

September 3, 2012 by rudy panucci

Up above is the second of three episodes of Radio Free Charleston devoted to Tribute To The Troops II. On August 11,Wood Boys Music took over the Saint Albans City Park Amphitheater for an all-day all-ages benefit show for our troops. Over eleven hundred dollars was raised for The Wounded Warrior Project and The National Guard Fund, and our cameras were on hand for the first half of the concert.Last week you heard Harrah, In The Company of Wolves, and Everpulse. The show kicked off with Cadence Weaver singing the National Anthem. You can see that show here:.

This week you will hear music from Breedlove, The Under Social, Remains UnNamed and Johnny Compton.

Monday, August 27, 2012

Episode 166 of RFC

Tribute To The Troops II On RFC 166

August 27, 2012 by rudy panucci
At the head of this post you see the first of three episodes of Radio Free Charleston devoted to Tribute To The Troops II. On August 11, Wood Boys Music took over the Saint Albans City Park Amphitheater for an all-day all-ages benefit show for our troops. Over eleven hundred dollars was raised for The Wounded Warrior Project and The West Virginia National Guard Foundation, and our cameras were on hand for the first half of the concert.

In the next three weeks you will hear music from Breedlove, The Under Social, Remains Unnamed, Deck of Fools, Johnny Compton, Point of Jerus, our guests on this week’s show, “Real American Hero Shirt,” are HarraH, In The Company of Wolves, and Everpulse. The show kicks off with Cadence Weaver singing the National Anthem.

Monday, August 6, 2012

Episode 165 of RFC

RFC 165 Presents Clownhole, circa 1989

August 6, 2012 by rudy panucci
Clownhole at the Playhouse
This week we present what might be my most self-indulgent episode of Radio Free Charleston. “Wild Adventure Shirt” breaks our usual format and uses a skit to set up vintage footage of a 1989 concert at the legendary and defunct Charleston Playhouse by the band Clownhole.

Clownhole was a punk trio consisting of drummer Randy Brown, bassist Chris (Flair) Canfield, and Defectors veteran John (Sham Voodoo) Estep. This concert was held during the Christmas season in 1989 and recently fell into my lap when Randy got in touch with me and put a copy of it in my hands.

A gambling parlor now stands at the site of The Charleston Playhouse

Wednesday, July 25, 2012

Episode 164 of RFC

Legally Blonde And Mother Nang on RFC 164

July 25, 2012 by rudy panucci
Up there is Radio Free Chaleston’s 164h episode, “Fighting English Shirt,” which features music from The Charleston Light Opera Guild production of “Legally Blonde” and a song from Mother Nang, along with a brief bit of strange uncredited animation.

Cameron Vance and Micah Atkinson
The CLOG production of “Legally Blonde” stars Micah Atkinson as Elle Woods, along with a large talented cast that includes Matthew Bryant, Allison Plants, Michael D. Gore, Cameron Vance, Toni Pilato, and Rudi Raynes-Kidder along with many others. The RFC cameras were allowed in for the first dress rehearsal, and we witnessed a show that is coming together quickly and looks like a lot of fun. We bring you two numbers from “Legally Blonde” this week, “Serious” and “What You Want.”

Monday, July 9, 2012

Episode 163 of RFC

RFC 163: Cool Music For Hot Times

July 9, 2012 by rudy panucci
Above you should see “Misfits of WV Shirt,” this is our low-key sixth anniversary show. After producing almost three hours of FestivAll coverage, we decided to just do a normal-length show for our anniversary. But it’s still a special show! Host segments were shot at Dutch Streetwear on D Street in South Charleston. You may remember our friends The Salvage Yard from The Charleston Town Center, well, they have a new name, and a great new, larger location in South Charleston, within sight of the Mound. We also have great music from Red Audio, Tofujitsu and Mother Blues. Plus we have animation.

Wednesday, June 27, 2012

Episode 162 of RFC

Part Two of FestivAll 2012 on RFC 162

June 27, 2012 by rudy panucci
i
Radio Free Charleston’s coverage of FestivALL 2012 continues this week with another bonus length episode

West Virginia Dance Company
featuring tons of music, dance, film, and other stuff.  The city became a work of art and we were there pointing our cameras right in its face.

We kick off with The Bob Thompson Unit, captured at The Shops at Bridge Road, performing on the West Virginia Music Hall of Fame bandwagon.  With the Bob Thompson Unit’s smooth jazz playing behind them, we cut to footage of the West Virginia Dance Company, recorded at the Charleston Town Center Mall.

Monday, June 18, 2012

Episode 161 of RFC

RFC Does FestivAll 2012: Part One

June 18, 2012 by rudy panucci
Every year during June, Charleston, West Virginia is a city that becomes a work of art. For the past few years, Radio Free Charleston has been there to immortalize parts of this city-wide event in internet videodom.  This is the first of two special episodes of Radio Free Charleston devoted to the sights and sounds of FestivAll 2012.

Included in this show is music from Red Audio, Andy Park, Emily Burdette, The Kanawha Kordsmen and Sweet Adelines and Paul Calicoat. We are also treated to an Effects Makeup demonstration by Rob “RJ” Haddy, a finalist on the SyFy program, “Face Off.”  Much of the show is devoted to the FestivAll Art Parade, while we finish with scenes of The East End Main Street Streetworks Art Auction and Celebration, and auctioneer Ted Brightwell.

Among the Art Parade fun you’ll see Razor Sharp Productions with Porkchop and Pig Girl, Dale Morton Studio Mascots, Zombies and ghouls from Shocka Con, The West Virginia Music Hall of Fame, The Chemical Valley Roller Girls, The Charleston Light Opera Guild and more!

We didn’t come close to making it to every cool event, but what we did capture was loads of fun. Next week we will bring you part two of our coverage, with music recorded at Thursday’s Derick Kirk Scholarship Benefit, and cool stuff from next weekend’s Capitol Street Art Fair, plus tons of other cool things.

Tuesday, June 12, 2012

Episode 160 of RFC

Radio Free Charleston’s 2012 FestivAll Preview

June 12, 2012 by rudy panucci
Above this text you see RFC 160, “Deep And Dangerous Shirt,” our FestivAll stream-of-consciousness preview/sampler show. We tell you about some of the cool things happening during FestivAll, and we give you some examples of the artists and performers on display. This is not, by any means, a comprehensive guide–for that, visit the FestivAll website. This is just a sampler, so enjoy!

We kick things off standing in The Lee Street Triangle, where, on Saturday July 16, at Noon, there will be a free edition of Dr. Sketchy’s Anti Art show, where anybody who wants to will get the chance to do some live figure drawing.