Episode 146 of Radio Free Charleston, “Pepper Fandango Shirt,” finds us driving around the state looking at the fall colors. We have great music this week with songs from Born of Conviction, John Lancaster, Gabriel, and the cast of Jack The Ripper, plus we have animation from Frank Panucci and an art film by yours truly.
Dan Kehde, the writer/director of "Jack The Ripper"
This episode of Radio Free Charleston is a major departure: It’s a documentary following the 2011 revival of the Dan Kehde/Mark Scarpelli musical, “Jack The Ripper.”
Produced by The Contemporary Youth Arts Company, this daring and complex piece of musical theater was pulled together in less than six weeks. Included in the show are interviews with Dan and Mark, intercut with “fly-on-the-wall” footage from the rehearsals leading up to opening night.You will also see footage of the original production from 2008, starring Ryan Hardiman. This is rare video that has never been seen by the gneral public before.
At the head of this post you will find RFC 144, “Mission Coalition Shirt.” This special episode of the show is devoted to this weekend’s big metal fest, to be held at The Sound Factory this weekend, September 9 and 10. You may remember that we wrote extensively about this show in the PopCulteer a couple of weeks ago.
On this edition of RFC you will find music videos by the Friday and Saturday night headliners, Karma To Burn and The Suede Brothers, plus a great video from Tomorrow Burns, and live performances from HarraH and The Scrap Iron Pickers.
Mission Coalition, Charleston’s first two-day metal fest will hold their first sonic onslaught with twelve bands spread over two nights. You will hear major acts like Karma to Brun and The Suede Brothers, plus local legends The Scrap Iron Pickers, Linework, HarraH, Saprogen, Tower of the Elephant, John Lancaster, Tomorrow Burns, The Number Six, Deadface Down and Nuns on Fire. Each night the show will start at 7:30 and last until well into the wee hours.
Frenchy and the Punk, Lippizzaner Stallions and DEVO Hats Highlight RFC 143
August 21, 2011 by rudy panucci
At the head of this post you will find the one-hundred forty-third installment of Radio Free Charleston, “Naked Gumby Shirt.” This episode departs from our usual formula by featuring three songs by the same band, Frenchy and the Punk. We also have animation by Frank Panucci, and a short film by K.D. Lett.
Frenchy and the Punk, who used to go by the name, “The Gypsy Nomads,” returned to The Empty Glass a couple of weeks ago for their third visit (the first with the new name). We were on hand with our cameras, and the band was on fire, so we ended up recording over half an hour of their music. Since we had so much fresh music from the band I decided to devote the entire episode to them this time. This is something I’m thinking about doing more often, so why don’t you use the comments section below to let me know what you think of the idea?
Positioned strategically at the head of this post, you should see the latest episode of Radio Free Charleston. Our 142nd installment is called “It’s Just A Flesh Wound Shirt.”
Radio Free Charleston’s Gigantic Fifth Anniversary Show!
July 6, 2011 by rudy panucci
At the head of this post, you see our bloated and self-indulgent fifth anniversary episode of Radio Free Charleston. When we first started doing Radio Free Charleston as a video web show, there was no guarantee that we would even make it to the end of our first year. So it’s gratifying to have hit this milestone, because on the Internet, five years is an eternity.
Mother Nang
However, I have to level with you. I almost didn’t see this milestone coming. The previous three weeks have seen me consumed with recording and producing our special FestivALL episodes of RFC. This didn’t leave me any time at all to plan an anniversary show. I really wanted to take July off.
Radio Free Charleston has not always observed our anniversary. The first anniversary of the show fell in the middle of a hiatus we took due to a family health crisis. I don’t think we really paid any attention until episode 75, which coincided with our third anniversary in 2009.
One Last Look At FestivALL 2011, Plus Two Great Outdoor Shows This Weekend
July 1, 2011 by rudy panucci
Larry Groce, the Pope of FestivALL
FestivALL 2011, That’s A Wrap!
Up at the top of today’s PopCulteer you will find the eighth and final episode of Radio Free Charleston’s video rewind of FestivALL 2011. FestivALl is such a wonderful part of Charleston that we felt it deserved extensive coverage. And extensive it was, with just under three hours of FestivALL crammed into our eight-episode trip through the art.
I hope our loyal RFC viewers can appreciate what a ridiculous undertaking this was. Your PopCulteer has been slaving away at the editing computer for the last two weeks, getting by with only a couple of hours of sleep a night, just so we could bring you our take on FestivALL 2011 as quickly as possible.
“Anything can happen day” on Radio Free Charleston includes music from Holy Cow, The Boatmen and Miss Behavin’; with wrestling from XMCW and a Swoard Dance by Jenna Brooke Swanson. This part seven of our everlasting gobstopper of a series of shows devoted to FestivALL 2011.
Tomorrow we wrap up our FestivALL coverage…or do we?
Dreaming Of Saint Stephen, Texting and Sasha Colette on RFC 138
June 28, 2011 by rudy panucci
"Helio McFadden" in the Space Opera
FestivALL may be over in the streets of Charleston, but it still lives on here in the PopCult blog. Today we’re going to revisit “Saint Stephen’s Dream: A Space Opera,” which was staged by WestVirginiaVille.com at the Unitarian Universalist Congregation last weekend.
We bring you a bit of the beginning of Douglas Imbrogno’s magnum opus, and we mix in Austin Susman’s entry in the Silent Film Competition. The show wraps up with Kentucky chanteuse Sasha Colette, performing in Davis Park, just two days ago.
Trillium Performance Arts Collective (photo by Lee Harrah)
We are driving into the second week of Radio Free Charleston’s ridiculously extensive coverage of FestivALL 2011. The clip you see up there is Radio Free Charleston 137, Part Five of our FestivALL 2011 coverage. Today’s show takes music recorded at the Derick Kirk Memorial Concert last Wednesday and combines it with dance recorded all over town during FestivALL.
Our music performed live at Capitol Roasters is provided by the Velvet Nomads, Comparsa, and The Voodoo Katz.
Professor Danger (photo by Lee Harrah)
Our featured dancers include the Capitol High School Dance Company, Mandy Petry, Brian Roller, Kevin Pauley, and Jeff Bukovinsky of the No Pants Players, Jenna Brooke Swanson and Raqs Shakti, Professor Danger, Kathleen Coffee, the Trillium Performance Art Company, and That Guy In Davis Park. Apologies go out to the Capitol High Dance Company for getting their name wrong in the show. We will correct that later in the week when they return.
This whole show was a lot of fun to edit, so you might see another dance montage later in the week. In the coming days, you will see episodes of Radio Free Charleston loaded with footage from “Saint Stephen’s Dream: A Space Opera,” the after-hours cafe’, the Silent Film Competition, the 72 Hour Film Challenge, the Capitol Street Art Fair, the Hale Street Antique Fair, XMCW’s LuchaFest, plus music from Sasha Collette, WATT4, Kathleen Coffee, Miss Behavin, and stuff we can’t remember at the moment.